Opened 6 years ago

Closed 6 years ago

#112 closed System Defect (invalid)

Missing GEOM ELI module in kernel

Reported by: pheet Owned by:
Priority: minor Milestone: 7.0
Component: System Configuration Version: 1.4.1
Keywords: geli geom eli encryption kernel Cc:

Description

THe PCBSD kernel in the 1.4 series is missing the GELI module. I feel this is incorrect as:

a) GELI is a standard part of the FreeBSD kernel since 6.0. I think that the PCBSD kernel should contain additional modules, but not remove modules from the GENERIC 86 kernel so the base system is consistent with what is stated in the FreeBSD handbook (considered cannon).

b) It was part of the default kernel in pc-bsd 1.3. It's a bit of a shock when upgrading to 1.4 that one can't access one's encrypted partitions.

Work around

Add the line geom_eli_load="YES" to /boot/loader.conf.

To load the module without having to reboot for loader.conf to take effect, as root in a console enter:

# kldload geom_eli

Change History (1)

comment:1 Changed 6 years ago by jpaetzel

  • Resolution set to invalid
  • Status changed from new to closed

GEOM ELI has never been in the FreeBSD default kernel.

See http://www.freebsd.org/doc/en/books/handbook/disks-encrypting.html section 18.16.2

Note: See TracTickets for help on using tickets.