Opened 6 years ago

Closed 6 years ago

#217 closed System Defect (worksforme)

Trying to ssh (or sftp) to a remote box causes error.

Reported by: slicer69 Owned by:
Priority: minor Milestone: 8.0
Component: System Tool Version: 8.0-ALPHA
Keywords: Cc: trac-bugs@…


When trying to ssh or sftp to a remote server, the following error message appears and the connection is dropped:

% ssh username@host

ssh_askpass: exec(/usr/local/bin/ssh-askpass): No such file or directory
Host key verification failed.


Below, the version number of PC-BSD is given as 8.0-alpha, but I'm actually using 8.0-beta.

Change History (6)

comment:1 Changed 6 years ago by kris

That sounds to me like an upgrade was done, and it didn't finish properly, or the disk ran out of space or something along those lines. Can you check "df -h" and do you see any full file-systems?

comment:2 Changed 6 years ago by slicer69

  • Priority changed from major to minor
  • Resolution set to fixed
  • Status changed from new to closed

I think you're right. I did the "df -h" check and all of the file systems have at least 5GB of space left. (Aside from procfs and devfs, of course.) But I popped the live DVD in and found ssh worked fine from there, so I think an update must have failed.

This install is just a few days old, so I'm going to re-install, do an update and see what happens. I'm going to mark this issue as "fixed", if it comes up again after the update, I'll re-open.

comment:3 Changed 6 years ago by slicer69

  • Resolution fixed deleted
  • Status changed from closed to reopened

Okay, I just performed a fresh install. Immediately tried to ssh to another machine and received the error

"ssh_askpass: exec(/usr/local/bin/ssh-askpass): No such file or directory Host key verification failed."

So, for some reason, it works fine for me when running off the DVD, but not when installed locally. Any suggestions would be welcome.

comment:4 Changed 6 years ago by kris

That is odd. On my fresh install here, I have /usr/local/bin/ssh-askpass, and it seems to work ok. What utility are you using to run SSH which is calling ssh-askpass? Does regular "ssh" from a konsole session work?

Also, if you run "dmesg" are you seeing anything weird, like disk read errors?

comment:5 Changed 6 years ago by slicer69

I checked and I do have that file, /usr/local/bin/ssh-askpass.
Actually, I rebooted the system this afternoon and, since then, I've been able to ssh and sftp into remote servers without any problems. (I had previously been using plain "ssh" and "sftp" commands and getting the error.)

As suggested, I looked at dmesg and found no errors or anything of concern. It sounds crazy, but I can't find any reason why it wasn't working and I haven't done anything (aside from reboot) which might have fixed it. But, it is working now, so I'm happy.

comment:6 Changed 6 years ago by slicer69

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.