Opened 4 years ago

Closed 4 years ago

#238 closed System Defect (fixed)

Booting Wireless 3945ABG error

Reported by: kavolorn Owned by: tim
Priority: major Milestone: 8.0
Component: Crash Handler Version: 8.0-RC
Keywords: Cc: trac-bugs@…

Description

Cant do any booting from my USB stick on Acer Aspire 5920G. wpi0 tells me that could not allocate memory resource.

http://www.imagechicken.com/uploads/1265282783079037200.jpg

http://forums.pcbsd.org/viewtopic.php?f=12&t=14947&sid=6b885a01f96313134d49a25539edfe98.

Change History (11)

comment:1 follow-up: Changed 4 years ago by kris

Lets first confirm that this indeed a bug with the wpi driver in 8.0:

At the boot-loader screen, selection option 8, escape to loader prompt.

Then enter:

unload
disable-module if_wpi
boot

Does it boot up normally after this?

comment:2 in reply to: ↑ 1 Changed 4 years ago by kavolorn

Replying to kris:

Lets first confirm that this indeed a bug with the wpi driver in 8.0:

At the boot-loader screen, selection option 8, escape to loader prompt.

Then enter:

unload
disable-module if_wpi
boot

Does it boot up normally after this?

Thanks for reply. Ive tried to make everything like you you just said. And It works :) So then, the problem is in if_wpi I think.

http://www.imagechicken.com/uploads/1265657450048420300.jpg

comment:3 follow-up: Changed 4 years ago by kris

  • Resolution set to wontfix
  • Status changed from new to closed

Great, at least that's a good work-around for the moment :)

Sounds like you aren't alone having issues with the wpi driver in 8.0 though:

http://lists.freebsd.org/pipermail/freebsd-net/2009-December/024013.html

Since this is a bug in FreeBSD itself its not something we'll be able to fix directly here, I would recommend that you file a FreeBSD problem report here:

http://www.freebsd.org/send-pr.html

If we can get some of the wifi devs over there to address this, then it'll be fixed when we start rolling PC-BSD 8.1 test versions after the release of 8.0.

comment:4 in reply to: ↑ 3 Changed 4 years ago by kavolorn

Thanks. I will send request to fix the problem.

comment:5 Changed 4 years ago by kavolorn

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Hello. I dont know if I'm right to reopen defect.
Something have changed here http://www.freebsd.org/cgi/query-pr.cgi?pr=143874.

comment:6 Changed 4 years ago by kris

Ahh, sounds like they fixed it in 8-Stable. Our 8.0-Release is just about ready, and shortly after that we'll begin doing builds on 8-Stable. Will you be able to test a 8-Stable version to confirm if this is fixed for you?

comment:7 Changed 4 years ago by kavolorn

Actualy I dont realy know how to test it int FreeBSD directly. The only way I see is:

  1. Install FreeBSD 8.0-RELEASE with sources
  1. Put if_wpi_load="YES" in my /etc/rc.conf
  1. Try to get same bootime fault
  1. Apply patch file
  1. Rebuild the kernel
  1. Try to boot up system without fault

If it sounds about right I will test it of course.

comment:8 Changed 4 years ago by kris

Thats probably the manual way to test it for sure, otherwise you can grab a copy of the FreeBSD 8-Stable snapshots from 2-17 and test with that. (Assuming the patch went in before then)

ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/201002/

Otherwise, If you can wait, I'll be rolling some PC-BSD 8-Stable versions in the next few weeks as well :)

comment:9 Changed 4 years ago by kavolorn

Sorry, It's been a long time since my last reply. So, am I able to download any version to test it now? :)

comment:10 Changed 4 years ago by kris

Yep, give this one a shot, see if it works with your hardware :)

ftp://ftp.pcbsd.org/pub/snapshots/8/

comment:11 Changed 4 years ago by kavolorn

  • Resolution set to fixed
  • Status changed from reopened to closed

So, booting fixed :) Thanks a lot! Now I hope I'll test connectivity somewhere.
The main problem remained is how to launch Ethernet card BCM5787A with ACPI enabled.

Note: See TracTickets for help on using tickets.