Opened 4 years ago

Closed 4 years ago

#265 closed System Defect (fixed)

BTX loader hang on after detecting a SATA drive

Reported by: crowncode Owned by: crowncode
Priority: major Milestone: 8.0
Component: Installer Version: 8.0-RC2
Keywords: Cc: trac-bugs@…

Description

BTX loader hang on after detecting a SATA HDD drive. If the SATA HDD is disabeled in BIOS then everything is OK.
PC BSD ver. 8.0 beta, tested, does install OK, with or without SATA. So, smth is wrong in 8.0 RC2 BTX loader or immed. after

Change History (5)

comment:1 follow-up: Changed 4 years ago by kris

That doesn't make a lot of sense, since the FreeBSD BTX loaders and such are exactly the same since the late 8.0-Alphas -> 8.0-Release. (All regular FreeBSD 8.0-Release). Can you confirm this still fails on PC-BSD 8.0?

comment:2 in reply to: ↑ 1 Changed 4 years ago by crowncode

CD Loader 1.2
Building....
Looking up /BOOT.... Found
Relocating.... and the BTX
Starting the BTX Loader
BTX loader 1.00 BTX version is 1.02
Consoles: internal video/keyboard
BIOS CD is cd0
Bios Drive A: is disk0
Bios Drive C: is disk1
Bios Drive D: is disk2
/

That's all. After displaying that slash character (not even rotating it :) ) the PC is dead. Ctrl+Alt+Del or Reset btn are the only options. This strange behavior is speciffic only to PC-BSD 8.0 RC2. All other previous versions (8.0 alpha, 8.0 RC) worked just fine, displayng smth about memory allocated and continued with the FreeBSD loader and all the stuff

comment:3 Changed 4 years ago by crowncode

  • Owner set to crowncode

comment:4 Changed 4 years ago by junme

I am having the exact problem any clues on this ?

FreeBSD 8 boots not PC-BSD 8

comment:5 Changed 4 years ago by junme

  • Resolution set to fixed
  • Status changed from new to closed

I changed a heap of stuff in the bios and it worked. I'll test which setting it was probably was LBA or acpi I turned them on

PCBSD 64 r8

Note: See TracTickets for help on using tickets.