Opened 6 years ago

Closed 5 years ago

#268 closed System Defect (fixed)

root partition with ZFS leads to installation failure

Reported by: atrox Owned by: kris
Priority: major Milestone:
Component: Installer Version: 8.0
Keywords: Cc: trac-bugs@…


I'm trying to install FreeBSD from PC-BSD 8.0. I created ZFS-partitions manually:

Installation was on 99% when it reported that error occurred and that installation is halted. Errors were smth about not being able to umount /mnt etc.
When I tried installation the same except / partition was left UFS+S, installation was OK.

I tried to get more specific errors too, but I didn't know how to mount ZFS partitions etc. Sorry :)

Change History (6)

comment:1 Changed 6 years ago by kris

  • Owner set to kris

I'll try to duplicate this here. Just to be certain, you created:

/ - ZFS
/var - ZFS
/tmp - ZFS
/usr - ZFS
swap - SWAP?

comment:2 Changed 6 years ago by atrox

Yup.. I actually set /var to be encrypted at first, but after testing the installation in multiple different ways, it seemed not to affect anything.

comment:3 Changed 6 years ago by atrox

Ah yes, I chose to install FreeBSD from the installer.

comment:4 Changed 6 years ago by atrox

I tried to install a system with very many different partitions with different filesystems. On 99% again, I got an error about not being able to umount /mnt/var which was ZFS. Others partitions were different variations of UFS.

comment:5 Changed 6 years ago by atrox

It seems that ZFS-partition's mountpoint cannot be set as a sub-folder: I set it to /usr/local (/usr being some UFS) and at the end of installation I got an error saying that parent of /usr/local doesn't exist (or smth).

comment:6 Changed 5 years ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

This needs to be re-tested on 8.1, this code has been cleaned up a lot, and should be fixed. Please re-open if you have still have issues.

Note: See TracTickets for help on using tickets.