Opened 4 years ago

Closed 4 years ago

#290 closed System Defect (3rdpartybug)

Broken Intel driver causing radom freezes and massive unstable behavure.

Reported by: patser Owned by:
Priority: blocker Milestone:
Component: XOrg Configurator Version: 8.0
Keywords: Intel driver broken Cc: trac-bugs@…, patser@…

Description

The Intel driver with 3d enables is extremely unstable on my HP Pavilion dv6000 notebook with Intel 945 GM graphics card.
It borks on a fresh installed desktop with composite enables/disables, with the desktop effects enabled/disabled.
Basicaly it borks on anything that requests graphical violance.. :P
The unstability now has reached such extend that I had to migrate to another system because pc-bsd is completely useless to me... :-(

Change History (14)

comment:1 Changed 4 years ago by patser

  • Milestone 8.0 deleted

comment:2 Changed 4 years ago by patser

  • Priority changed from critical to blocker

comment:3 Changed 4 years ago by patser

  • Component changed from PBI System to Misc

comment:4 follow-up: Changed 4 years ago by patser

After crusing the internet I discovered that this is not just a PC-BSD intel driver issue, aimular issues have been reported in the intel drivers for both OpenSuSe? en Ubuntu Linux.

comment:5 in reply to: ↑ 4 Changed 4 years ago by patser

Simular issues, I'm such a dork with typing. :)

comment:6 Changed 4 years ago by patser

  • Priority changed from blocker to critical

comment:7 Changed 4 years ago by patser

Temporary fix seems to be turning desktop enhancements and composite off.

comment:8 Changed 4 years ago by patser

  • Owner set to patser
  • Status changed from new to assigned

Been searching all over for a temporary fix, nothing I do seems to work sinds the server starts some settings by default and ignores the settings I put in xorg.conf to turn them off.
Things I realy need to ditch are XVideo (bugged like hell) and some limitations to DRI which also has more bugs then a beehive has bees. :-)
There also might be a onnection to some of the other settings (composite, rendering accels?), if anybody outthere has any suggestions please let me know, cause I'm not getting any further on this thing.

Thanx. :-)

comment:9 Changed 4 years ago by patser

  • Owner patser deleted
  • Status changed from assigned to new

comment:10 Changed 4 years ago by patser

  • Component changed from Misc to XOrg Configurator
  • Priority changed from critical to blocker

comment:11 Changed 4 years ago by patser

  • Cc patser@… added

comment:12 Changed 4 years ago by kris

A few days ago Xorg 7.5 + new intel drivers / DRI went into the FreeBSD tree. We'll probably need to have you test on that platform to see if this has been resolved. We should have a new snapshot available in a week or two available here:

http://lists.pcbsd.org/mailman/listinfo/testing

Once we post it, please give it a whirl and see if the driver acts properly now :)

comment:13 Changed 4 years ago by patser

Oke, I kinda lost focus on this due to urgent family matters (say sorry). But I have subscribed to testing now and will try to find time to give it a whirl.

comment:14 Changed 4 years ago by kris

  • Resolution set to 3rdpartybug
  • Status changed from new to closed

Marking this as 3rdparty bug, since its intel driver related.

Note: See TracTickets for help on using tickets.