Opened 4 years ago

Closed 4 years ago

#292 closed System Defect (fixed)

Caps Lock confusingly mapped to Ctrl by default

Reported by: dwhite Owned by:
Priority: major Milestone:
Component: System Configuration Version: 8.0
Keywords: Cc: trac-bugs@…

Description

By default for the US locale, pc-sysinstaller sets the nocaps option on the generated kxkb configuration file in the user home directory skeleton which turns Caps Lock into Ctrl. While old-time Sun Type 5 keyboard users probably appreciate this, it is unexpected behavior for most users who expect Caps Lock to operate as it always has on PCs.

Please remove the kxkb option settings from pc-sysinstaller and offer 'us-sun' as an alternative locale for people who want the Caps/Ctrl? swap prior to first login.

The offending configuration happens in pc-sysinstall/backend/functions-localize.sh.

The settings can be changed on a per-user basis in the Regional & Language -> Keyboard Layout panel, which is non-obvious since there are other keyboard configuration top level categories.

Change History (2)

comment:1 Changed 4 years ago by dwhite

  • Summary changed from Caps Lock disabled by default and no UI to change to Caps Lock confusingly mapped to Ctrl by default

comment:2 Changed 4 years ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report, fixed :)

http://trac.pcbsd.org/changeset/6592

Note: See TracTickets for help on using tickets.