Opened 5 years ago

Closed 5 years ago

#329 closed System Defect (fixed)

Installation error claims /var is too small when it isn't

Reported by: joehache Owned by: kris
Priority: major Milestone: 8.1
Component: Installer Version: 8.1-RC1
Keywords: /var /usr Cc: trac-bugs@…


I am attempting to install PC BSD 8.1 RC1 amd64 on an Intel i7 with two hard drives (SSD is ada1 and normal is ada0).

My first attempt involved me creating partitions manually with /var being set to 2GB; I then got an error message saying "'/var' file-system is below the required minimum: 8000. I thought that was a high minimum for /var, but switched it to 8GB, then 10GB and got the error both times before aborting the install. I thought that perhaps it wasn't reading the new value of /var.

Next install I try the same thing, putting in the following values:

ada1 / 2048 ZFS
ada1 /usr 5574 ZFS
ada0 none 12288 SWAP
ada0 /var 10240 ZFS
ada0 /tmp 10240 ZFS
ada0 /root 1024 ZFS
ada0 /home 819200 ZFS

After getting the same error message, I try different variations thinking it may be the ZFS type, but none of the three UFS options work either. I am not able to continue with the installation, and do not want to auto-partition as I want my SSD to receive / and /usr which should be the least written to once the system is up and running.

Change History (3)

comment:1 Changed 5 years ago by joehache

  • Keywords /var added
  • Priority changed from blocker to critical

This issue occurs only when choosing to install PC-BSD. Choosing to install FreeBSD from the installation GUI does not cause this error. Reducing to critical as I have a possible work-around of installing FreeBSD first then upgrading components as needed to achieve PC-BSD 8.1.

comment:2 Changed 5 years ago by joehache

  • Keywords /usr added
  • Priority changed from critical to major

Further testing has shown that the system wants more space in /usr; giving /usr more space clears this error. This needs to be fixed so that users wanting to customize their disk partitions know what the minimums are for each partition.

comment:3 Changed 5 years ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report. Fixed it, was just a typo in the "/usr" space requirement check :)

Note: See TracTickets for help on using tickets.