Opened 4 years ago

Closed 3 years ago

#485 closed System Defect (fixed)

Cannot eject CD from file manager

Reported by: bitgeist Owned by: joshms
Priority: minor Milestone:
Component: Misc Version: 9.0-RELEASE
Keywords: Cc: trac-bugs@…


This is really on 9.0 Release, but that option isn't available in the ticket system.
If cd was in the drive when the system boots, can't eject. If cd put in after user logs in, user can eject it.
Click on file manager, click on the PC-BSD install media that was still in the computer after installation. Click on the little eject icon, or right click and select eject. Get the following error: "Cannot eject volume. There was an error ejecting the volume or drive. org.freedesktop.Hal.Device.Volume.UnknownFailure?: Cannot get volume object". File manager then closes behind the error popup. From the command line, the mount command does not show the volume as mounted. I can use the eject button on the drive to eject it.

Change History (3)

comment:1 Changed 4 years ago by dlavigne

  • Version changed from 9.0-BETA3 to 9.0-RELEASE

Thanks for version reminder. Changed to 9.0-RELEASE.

comment:2 Changed 3 years ago by joshms

  • Owner set to joshms

I have not been able to duplicate your problem. I tried it on native PCBSD installations and with several different setups in virtual box and still can't get it to duplicate using file manager or via the console. Can you tell me more about your setup? What kind of optical drive are you using (make / model)? Also have you tried another optical drive to see if the problem still happens?

comment:3 Changed 3 years ago by joshms

  • Resolution set to fixed
  • Status changed from new to closed

The install media can only be ejected in 9.1-BETA1 after rebooting, and I was not able to duplicate your problem so we will now close this ticket.

Note: See TracTickets for help on using tickets.