#764 closed System Defect (fixed)

system panic on first boot

Reported by: sheldoni Owned by: Kris
Priority: critical Milestone:
Component: System Configuration Version: 9.2-RELEASE
Keywords: Cc: trac-bugs@…


I installed PCBSD 9.2 and the install goes fine. Upon the next boot my screen goes blank, nothing ever comes up. I installed the GAG bootloader and upon rebooting, I was able to get to the ascii FreBSD boot screen with the red characters sort of forming the daemon logo. I selected single user and verbose boot modes. I booted and the screen scrolled various stuff and stopped with the following:

Device configuration finished.
procfs registered
ZFS storage pool version: features support (5000)
panic : No usable event timer found!
cpuid = 0
KDB : stack backtrace:
db_trace_self_wrapper() at db_trace_self_wrapper + 0x2a/frame 0xffffffff81bb89a0
kdb_backtrace at kdb_backtrace + 0x37/frame 0xffffffff81bb8b80
panic() at panic + 0x1ce/frame 0xffffffff81bb8b60
cpu_initclocks_bsp() at cpu_initclocks_bsp + 0x3f2/frame 0xffffffff81bb8b80
initclocks() at initclocks + 0x20/frame 0xffffffff81bb8b90
mi_startup() at mi_startup + 0x77/frame 0xffffffff81bb8bb0
btext() at btext() + 0x2c
KDB : enter : panic
[thread pid 0 tid 100000]
Stopped at kdb_enter + 0x3b : movq $0, 0xaef5b2 (%rip)

I hope that this helps resolve this issue.

Change History (8)

comment:1 Changed 23 months ago by sheldoni

I forgot to mention what type of system I have.
ASUS P8Z68-V PRO motherboard
Intel i7-2600k processor
16 Gb RAM
2Tb Seagate drive

comment:2 Changed 23 months ago by joshms

  • Priority changed from major to critical

After some brief preliminary research i'm worried there is some kind of ACPI issue that has developed with FreeBSD 9.2. I'm going to install it here on my test systems with ACPI enabled and see if I can generate the same issues others have been having. In the mean time can you turn off ACPI and see if the problem persists? I understand that might not be feasible, but at least we would be able to isolate whether or not it is indeed the problem. On the other hand if ACPI is disabled will you try flipping it on and seeing if anything changes? Thank you for reporting this and if you find any other pertinent information please let us know.

Best Regards,


comment:3 Changed 23 months ago by sheldoni

I turned off ACPI in the ascii menu by selecting, first the number 5 option, then the number three option, and the results are the same.

comment:4 Changed 23 months ago by joshms

  • Owner set to Kris

comment:5 Changed 22 months ago by sheldoni

I have tried to duplicate the same error using FreeBSD 9.2 on the same machine and have not gotten the same result. The boot goes normally and allows me to login. There is no kernel panic due to the "no suitable event timers found" message.

comment:6 Changed 22 months ago by sheldoni

The previous comment forgot to mention that the install was on an ASUS P8Z77-V PRO motherboard with an Intel i5-2500k processor. I should also mention that other installs on boards with AMD Phenom II X4 processors go just fine. Does this mean that there is some Intel specific code in the installer that is causing our problems?

comment:7 Changed 22 months ago by sheldoni

The latest DVD of 3 November installs fine and boots up into the user configuration screen and works just fine. I am running on an intel i5-2500k processor and the above mentioned ASUS motherboard.

comment:8 Changed 22 months ago by kris

  • Resolution set to fixed
  • Status changed from new to closed

So it sounds like this was fixed in the latest 9.2 release? Great!

BTW, ACPI does need to be enabled on most systems for it to boot :)

Note: See TracTickets for help on using tickets.