#776 closed System Defect (wontfix)

Bootcamp support not working

Reported by: malco_2001 Owned by: kris
Priority: major Milestone:
Component: Installer Version: 9.2-RELEASE
Keywords: Cc: trac-bugs@…


During a fresh install on a bootcamp partition with refined everything appears to go fine with no errors. This is if I choose install option for beginners and choose the partition "lnux data" instead of selecting entire drive.

Upon reboot refined see's the freebsd partition. After attempting to boot I get a message that appears to be the freebsd bootloader telling me it can't find the kernel.

If i try again using advanced install no matter what options I check use gpt, force 4k, stamp grub I get an error about dd saying operation not supported.

Change History (4)

comment:1 Changed 22 months ago by malco_2001

After further research I don't believe this is simply a grub issue. This person is showing the same error I am.


comment:2 Changed 22 months ago by malco_2001

It seems that refind isn't loading grub. Instead it seems to be simply boot the kernel directly and the zfsloader doesn't like the way it is trying to access the pool as shown in the link to the FreeBSD mailing list by another FreeBSD user.

Now that I think about it I don't believe I've ever gotten ZFS to work with refind properly. I have been able to get it to work with UFS and that might explain why previous PCBSD releases worked.

Therefore I believe this is more or less something that should be solved by fixing refind. I do know of some workarounds like installing grub in /EFI/ on the HFS partition. I know that works but to me that's not a good idea for playing well with the boot manager control panel as it updates entries in grub.cfg.

I've noticed that there is an entry for FreeBSD in refind, but there is not an entry for PCBSD. So I think as far as a better solution I am going to see if I can create a custom entry in refind to fix. If this works I will create a "PCBSD" template for refind and submit a patch to the developer(s) of refind. That way it would be fixed more or less out of the box by just installing refind it would pick up and properly label PCBSD. The hard part will likely be making it work with and without grub. Feel free to resolve this however if you like unless you want me to continue to post my progress here.

Last edited 22 months ago by malco_2001 (previous) (diff)

comment:3 Changed 22 months ago by malco_2001

This page seems to explain why zfsloader is an issue for hybrid gpt/mbr installs.


comment:4 Changed 22 months ago by kris

  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for the info. Once the FreeBSD kernel can properly load via EFI then we should be able to dual-boot using GRUB on OSX. Feel free to post any additional info you find though.

Note: See TracTickets for help on using tickets.